Targeting .NET 3.5

Sep 7, 2011 at 9:18 PM

Is there any particular reason why FsUnit was upgraded to .net 4.0 ? I don't see anything 4.0 specific and I need it for a project using .net 3.5

I think all libraries should try and be as backwards compatible as possible, so FsUnit could just target 3.5... but if for some reason someone wants a 4.0-specific build we could look into multitargeting.

Thoughts?

--
Mauricio

Developer
Dec 11, 2011 at 4:17 AM

Great points Mauricio. I have fixed this in the 0.9.1.1 NuGet package release and implemented multi-targeting into the Fake build.

Dec 13, 2011 at 12:48 AM

Thanks Daniel! The reason I asked for this was to enable multitargeting in FSharpx... I switched to an "inline" FsUnit there (it's a single file after all), but now that you fixed this we can go back to using the FsUnit NuGet package and do proper multitargeting. Wanna give it a try? :)

Cheers,
Mauricio 

Developer
Dec 13, 2011 at 2:50 AM

Yeah, that sounds great!